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1. General 
Prerequisites: 

• Google Account + Google Drive 
• Internet connection 

In a nutshell, FitSheet is designed for easy workout planning for different days, entering 
them into a calendar, tracking progress and achievements, as well as monitoring body 
changes. It can be used by both coaches and individuals who want to have better and 
easier control over their training. FitSheet also works on mobile devices, making it easy 
to use at the gym, during outdoor workouts, anywhere. 

FitSheet is a spreadsheet created in the Google Sheets.  

Note: FitSheet cannot be used in Excel as it contains built-in scripts in a 
language that Excel does not support.  

To begin, download the sheet and save it to your Google Drive (which allows for 
simultaneous use from both your phone and computer — recommended!). A Google 
account is required. 

Access and use: 

FitSheet can be accessed from both a computer and a smartphone (preferably with the 
Google Sheets app installed). However, the initial training setup (training generation) 
must be done on a computer. 

1.1. Downloading the spreadsheet 

To download the spreadsheet to your Google Drive: 

a) Use the link received after purchasing the FitSheet. 
b) Click File > Make a copy 
c) Choose a name, location, and click Create a copy. 
d) From now on, the spreadsheet will be available in your account in the location 

chosen in the previous step.  

1.2. Script Authorization 

The spreadsheet operation is based on scripts, which require special permissions. 

The first use of interactive options, e.g. generating a workout sheet, prompts for 
authorization: 



 

Figure 1 Authorization Window 

• In the first window, click OK 

• In the next step, select your Google account, then click Advanced > Open: 
FitScript (unsafe) and in the last step click Allow  



 

Figure 2 Authorization, step 2 



 

Figure 3 Authorization, step 3 



 

Figure4 Authorization, step 4 

From now on, the scripts will be active and the sheet will function properly.  

 

  

  



2. Configuration (Config Sheet) 

 

Figure 5 Configuration sheet 

 2.1. Sheet overview 

First header row: T1, T2 etc. labels correspond to individual workout routines. Each 
workout routine is a unique set of selected exercises that can be assigned to different 
days. For example, you can plan 3 workout routines, which will be repeated in a weekly 
cycle, T1 on Mondays, T2 on Wednesdays, T3 on Fridays. However, the setup is up to 
you. You can configure up to 7 workout routines. 

Second selection row (checkbox): operations on exercises can be performed after 
selecting the checkbox — both individually and in a batch mode. The available 
operations are visible in the Options menu. The menu is only accessible from a 
computer. The options were discussed in section 2.2.  

 

  

Name: Any name given to the workout routine. E.g. "Biceps and triceps" or "Monday". 
The name will also be visible in the workout routine view after it is generated (e.g. T1 
sheet) and in the calendar. 



Number of sets: Here you choose how many sets of exercises you want to do in a given 
workout routine. The correct setting of this parameter is very important, as it determines 
the view of the workout routine. 12 sets is the maximum. 

Warm-up: Here, you choose whether you want a warm-up to be included for a given 
workout routine. Having a warm-up enabled means that in the workout routine view, 
exercises selected in the warm-up section below will show up. Possible values are "Yes" 
and "No". 

Finish: Here, you choose whether you want to enable a finish for a given workout routine 
(exercises after the main workout). Having a finish enabled means that in the workout 
routine view, exercises selected in the finish section below will show up. Possible values 
are "Yes" and "No". 

Exercise time: Choose in minutes, how long it takes you to perform one exercise on 
average (not 1 repetition). So for example, if the exercise is push-ups and you want to do 
20 repetitions, choose how long it takes on average to do 20 repetitions. This parameter 
is of secondary importance and is used to estimate the workout routine time (total and 
remaining). The default value is 1 minute. 

Warm-up (orange background): a section designed for selecting warm-up exercises 
(max. 10). Select exercises from a drop-down list, which is populated with exercises 
from the database. If necessary, you can add your own exercises if they are not in the 
database. For how to add your own exercises, section 7. 

Main exercises (green background): a section designed for selecting main exercises 
(max. 20). Select exercises from a drop-down list, which is populated with exercises 
from the database. If necessary, you can add your own exercises if they are not in the 
database. For how to add your own exercises, section 6. 

Finish (blue background): a section designed for selecting finish exercises (max. 10). 
Select exercises from a drop-down list, which is populated with exercises from the 
database. If necessary, you can add your own exercises if they are not in the database. 
For how to add your own exercises, section 6. 

Main muscle group:  this row provides information about the muscle group which will 
be most intensively exercised during the workout routine. This information is generated 
automatically depending on the exercises selected for the workout routine. If there are 
several different ones with the same highest number of exercises, the text 'Many' will 
appear.  

Estimated workout time: automatically calculated estimated workout routine time. 
This value is based on the user-input information: the time of the one exercise from the 
row no. 7, and also depends on the number of exercises, sets, and the warm-up/finish 
duration. 



  

2.2. Description of options illustrated by configuring the first workout 
routine, T1 

 

Note: The configuration (generation/removal) of the workout routine 
must be done on a computer.  

 
Figure 6 View of the options list 

a. Configuration 
• Give a name in B3. 
• Choose the number of sets in B4. 
• Choose whether you want a warm-up and a finish (B5-B6). 
• Provide the average exercise time. 
• In the fields B9-B48, select exercises (for now without setting repetitions and 

weights — these values will be set on the next sheet). If you want to set fewer 
exercises than the maximum, leave a dash in the redundant fields or leave the 
field blank. 

A sample workout routine (exercises were chosen randomly, do not pay attention to their 
type, it's just an example): 



 
Figure 7 Sample exercises in a workout routine  

 
b. Generating a workout routine (Generate workout tabs option) 
• After selecting the parameters, check the checkbox in B2. 
• Click Options > Generate workout tabs.  



 
Figure 8 Generating workout tabs 

• A sheet named T1 should be generated. You will see the following message:  
 

 
Figure 9 Confirmation of workout routine sheet generation 

  
If this did not happen, there must have been an error. If everything went according 

to plan, the T1 sheet will appear.  
It will include all exercises in as many sets as selected in the configuration. In 
case of a mistake, the entire sheet should be removed.  

 
 
c. Removing your workout routine 
• Select the appropriate checkbox (for the workout routine T1, it will be B2) 
• Options > Delete workout tabs. 



  

Figure 10 Deleting workout tabs 

  

d. Get random exercises 

 

Figure 11 Getting random exercises 

It is used to fill the exercise selection area with random exercises from the database. 
This option can be used to test generating a workout routine sheet and other operations, 
such as deleting. 

e. Remove exercises from workout 



 

Figure 12 Removing exercises from the workout routine 

This option clears all selected exercises in rows 9 to 49. In case of accidental use of the 
option, the operation can be undone by pressing CTRL+Z, or using the arrow: 

 

f. Hide/show empty rows 

 

Figure 13 Hiding empty rows 

This option is used to hide unused rows to increase the readability of the 
configuration sheet. Below, we show what the view looks like before hiding and after 
hiding. 

Before hiding: 



 

Figure 14 View before hiding empty rows 

  



After hiding: 

 

Figure 15 View after hiding empty rows 

g. Save workout in history 

 

Figure 16 Saving workout in history 

This option can only be used while on the training sheet, e.g. T1, T2, etc. It will be 
discussed when discussing the training sheet. 

h. Remove last workout from history 



 

Figure 17 Saving workout in history 

This option can only be used while on the training sheet, e.g. T1, T2, etc. It will be 
discussed when discussing the training sheet.  

3. Workout routine view (sheets T1, T2 etc.) 

3.1. General 

On this sheet, you need to complete the configuration by selecting the weights, 
repetitions, and rest time for the exercise. 

Note: if the parameters are the same for all sets, it is enough to fill them 
in for the first one, and then use the option Duplicate parameters from 

1st set. The warm-up and the finish are filled in separately. 

This sheet is the most important one focusing on the actual training.  

Here, you can track the progress of exercises — by checking off on the exercises already 
completed. You will see the progress in the form of the remaining exercises indicator 

(field I2)  and the estimated training time in C:D3: 

.  

The field H2   shows which exercise you have previously marked as finished. The 
number in the blue field indicates the set, and the second one, indicates the exercise 
number. They are assigned in column A.  



 

Figure 18 Workout routine view 



3.2. Workout routine number 

 

Figure 19 Workout routine view, indicated workout routine number 

The workout routine number always corresponds to the number on the Conf sheet. It 
must not be changed. 



3.3. Workout routine name 

 

Figure 20 Workout routine view, indicated workout routine name 

The name of the workout routine is pulled from the Conf sheet based on the workout 
routine number. It must not be changed here. If you want to change it, please do it on the 
Conf. sheet. 



3.4. Number of sets 

 

Figure 21 Workout routine view, indicated number of sets 

The number of sets of the workout routine is pulled from the Conf sheet based on the 
workout routine number. It must not be changed here. If you want to change it, please do 
it on the Conf. sheet. 

Note: If the number of sets changes after generating the workout routine sheet, the view 
must be reset for the appropriate number of sets to be displayed on the workout routine 
sheet. To do this, use the option from the Select Operations menu > Refresh view. Then, 
the updated number of series will show up. 

 



3.5. Main group 

 

Figure 22 Workout routine view, main muscle group indicated 

The main muscle group is information about which set has the highest number of 
exercises selected in the training. This information is generated automatically based on 
the information about the muscles involved in the exercises during the generation of the 
workout routine and retrieved from the Conf sheet. If there is ambiguity, for example, if 
there are 4 exercises, with two for the legs and two for the biceps, the shown value is 
Many. 

3.6. Operations 

a.     Refresh view 

Used to refresh the view. By default, after creating a sheet, you can see as many sets as 
selected in the configuration. If you want to change the number of sets after creating the 
sheet, you need to change it in the configuration sheet, and in the workout routine view, 
use the Refresh view operation. 

b.     Duplicate parameters from 1st set 



To complete the workout routine, you need to enter data about the weights and 
repetitions, as well as the duration of the rest after the exercise. To avoid doing this for 
the entire workout routine separately, simply fill in the fields for the first set, and then 
duplicate them for all sets using this option. 

c.       Clear parameters 

This operation is used to clear all set parameters. 

d. Check all 

Here, you can bulk mark all exercises as completed. 

e.   Uncheck all 

Here, you can bulk mark all exercises as uncompleted. 

f.       Hide/show details 

This option is used to display/hide additional information about exercises, e.g. the 
muscles involved in the given exercises. 

g.      Start new 

This operation is used to clear columns H and I. This means resetting the completion 
selection for exercises and the indicated difficulty levels. In short, use this option before 
starting your next training session. It should be remembered that if the previous one is 
to be stored, it should be saved using the Options > Save workout in history option. 



3.7. Nearest workout 

 

Figure 23 Workout routine view, indicated nearest workout 

Here, will appear the date of the next training session, if this workout routine is placed in 
the calendar, i.e. on the Calendar sheet, the x symbol x is inserted for it on a day that is 
not in the past (today or in the future). 

Note: To display the date of the nearest workout session, use the 
Refresh view option. 



3.8. Number of exercises remaining to complete 

 

Figure 24 Workout routine view, indicated number of exercises to be completed 

Indicates how many exercises are left to complete. The number decreases as you mark 
the exercises as completed using the checkbox. 



3.9. Workout routine status (icon) 

 

Figure 25 Workout routine view, status icon 

During your workout the following symbols appear ę symbol      . When all exercises are 

marked as completed, it changes to       . 



3.10. Exercise number 

 

Figure 26 Workout routine view, exercise number 

To the left of each exercise, there is its number. The number is always two-part. The first 
element is the rocket symbol for the start, finish flag symbol for the finish, and for the 
remaining exercises, a numbers of the given set on a blue background. This number is 
then transferred to the H3 field upon completing the exercise. Thanks to this, you can 
quickly see which exercise from the current set was completed last, which makes your 
training easier. 



3.11. Last finished 

 

Figure 27 Workout routine view, last finished 

Here, the last finished exercise shows up. 



3.12. Weights column 

 

Figure 28 Workout routine view, exercise weight 

In this column, select the weight for a given exercise. In addition to numerical values, 
you can choose NA — not applicable, or MAX — maximum. 



3.13. Repetitions column 

 

Figure 29 Workout routine view, exercise repetitions 

In this column, select the number of repetitions for a given exercise. In addition to 
numerical values, you can choose NA — not applicable, or MAX — maximum. 

 



3.14. Duration/rest column 

 

Figure 30 Workout routine view, exercise duration 

In this column, you select the duration in minutes for warm-up and finish, while for the 
remaining exercises, you select the rest time after completing the exercise and before 
moving on to the next one. Scheduled rest times affect the estimated training time. 



3.15. Completion column 

 

Figure 31 Workout routine view, exercise completion status 

The completion column is where, after finishing a particular exercise, you check the 
checkbox to confirm that you have completed this exercise. Checking the checkbox 
affects the number of exercises to be completed and the estimated remaining training 
time. 



3.16. Difficulty column 

 

Figure 32 Workout routine view, exercise completion difficulty 

In this column, you can specify for each exercise how difficult it was to perform it. This 
will help you know in the future whether you should increase or decrease the workload, 
and whether you make progress. 



3.17. Additional columns 

 

Figure 33 Workout routine view, muscle columns 

Additional columns appear after clicking the Select Operation > Show/hide Details 
option. 

Here are the details about the muscles involved in the specific exercise, as well as the 
muscle group. These pieces of information are used to identify the previously described 
set of muscles. 

4. Workout history (computer only) 

 

Figure 34 History — saving and deleting workout  



4.1. Saving workout in history 

The options to save a workout to history and delete it from there are available only from 
a computer and from the workout routine sheets (T1, T2, etc.). 

The save is used to track progress and access past training sessions. After using this 
option, a workout history sheet will be generated for the specific workout routine, e.g. 
T1_h for T1, and so on. 

Note: It is recommended to save workouts on a regular basis, because 
in order to proceed to the next workout, the completed one has to be 
reset (Select operation > Start new), and this deletes the difficulty 

indication and completion status. 

 

Figure 35 Sample workout history view 

If there is already a workout session from the past saved in the story, the most recent 
one will be added before it, in columns C:I. 



4.1. Deleting workout from history 

To delete the last workout session from the history, go to the appropriate history sheet, 
e.g. T2_H, and then click Options > Remove last workout from history. 

5. Fitness and measurements (FitTest sheet) 
The Fittest sheet is used to monitor changes in the body and progress in test exercises. 
To track progress, you can repeat the same exercises at regular intervals. If you make 
progress, you should be able to accomplish more and more of them over time. The sheet 
is open, so feel free to add new lines in selected places here. In the last column, you can 
set a goal that you want to achieve. 

Available operations: 

a.   Add measurement/parameter 

Clicking this option will add a new column in the penultimate position of the table. You 
can enter current measurements or exercise data in it. 

The items Exercise 1, 2, etc. can be named as desired, for example, push-ups. 

The ratio of the waist to the chest and the chest to the hips is calculated by formulas. 
These formulas should not be changed. 



 

Figure 36 Fittest view 

    Remove the last parameter column 

This option causes the deletion of the last measurement. 

6. Scheduling workout sessions (Calendar sheet + C_arch) 

 

Figure 37 Calendar view 

a. General 



In the Calendar tab, you can schedule workouts for each day to better visualize your 
plan. Mark the 'x' in the field of the appropriate day. On the sheet of a given workout 
routine (e.g. T1), the date of the nearest session  will 
appear in the appropriate field — however, in order for this to happen, it will be 

necessary to refresh the sheet first using the Refresh View option . 

The workout routine names in column B are automatically transferred from the 
configurator and must NOT be edited here, as it would stop them from being updated 
later. 

b. If a given day has already passed, for example, today is the 21st, and in column C it is 
20, you can transfer past days to the archive by selecting the operation: Archive old.  

 

Figure 38 Options available in the calendar 

Then a maximum of 7 columns will be moved to the C_arch sheet. Only dates older than 
the current date are subject to transfer. To move more than 7 days, you can use the 
option multiple times. 

c. Adding days 

When you run out of days on the calendar (in the example screenshot above, the range 
ends on 19.10), you can add more using the Add new days operation. 7 new days are 
always added as well. 

d. The row 2 indicates which days are workout days. That is, if for a given day you select 
any workout routine with an X, in the row 2 there will be displayed information that this 
day is your workout day.  



 

Figure 39 Workout days 

e. The row 3 shows the day of the week to facilitate navigation throughout the calendar 
and the week. 

 

Figure 40 Days of week 

Note: Do not add columns manually, as built-in formulas and scripts 
may stop working correctly. 

7. Exercise base 
FitSheet has a database of nearly 900 exercises, which can still grow. The exercise 
database is located in the E_DB sheet, which is hidden by default to minimize the risk of 
accidental tampering. 

To uncover the hidden sheet, click the button with three horizontal lines in the bottom 
left corner and select the name E_DB. 



Note: Any unauthorized modification of this sheet may result in the 
exercise being removed from the database. Please use caution. 

a. Adding new exercises 

To add a new exercise, go to the first empty cell in the E_DB sheet and then enter the 
exercise name. Optionally, you can add the muscles involved in this exercise in columns 
C:G. After adding the exercise, it will be visible in the drop-down lists in the 
configuration.. 

 

Figure 41 Exercise Base 

  

8. Summary 
If you have any questions, feel free to contact me at mkucharski8@gmail.com.  

mailto:mkucharski8@gmail.com
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